UltraSoundSweep: depth change while recording

Hi ImFusion technical support,

While doing an echocardiography exam, one may adjust the depth of the US image.

We tested this case and it looks like 3D Freehand Ultrasound Workflow doesn’t reflect depth change in the generated imf file.

  • The imf file contains only one UltrasoundSweep object which has only one FrameGeometry, so there is only one depth
  • spacing field is always set to the same value

Are we missing something?

Thank you,


We do not support different image specifications in a single imf file. There is one global header for the entire sequence with spacing, frame geometry etc. Please make sure to stop the recorder when you change depth, and then start again.

We currently automatically stop recording when the image dimensions change, but apparently we’re missing the condition to stop when only the spacing changes (only the case if the image is always rendered into the same pixel grid as e.g. with Clarius). We’ll update this into the next versions, so thanks for raising this question!

In general, when dealing with tracked probes, you might want to consider using the US calibrator as well, i.e. check in the Advanced Settings / Calibration tab of the US recorder (needs latest version). If the depth changes, the calibration will automatically updated to reflect that.

Best regards,