OneShot D435 problem

Hi, my problem is not RecFusion-related, but the Oneshot capability of ImFusion Suite. Could you make an ImFusion Suite forum category?

Our OneShot scanner uses Intel D415 depth cameras with Odroids. Now we would like to test using Intel RealSense D435i cameras instead of the properly working D415s, because of the need of the wider FOV due to proximity of the target. But we’ve got the next error when tried to start ethersense server:

odroid@odroid:~/oneshot$ ./
Number of arguments: 1 arguments.
Argument List: [‘’]
13/08 15:21:19,969 INFO [548170272784] (backend-hid.cpp:1139) Failed to read busnum/devnum. Device Path: /sys/bus/iio/devices/iio:device0
13/08 15:21:19,975 INFO [548170272784] (backend-hid.cpp:1139) Failed to read busnum/devnum. Device Path: /sys/bus/iio/devices/iio:device0
13/08 15:21:19,976 WARNING [548170272784] (ds5-factory.cpp:1119) DS5 group_devices is empty.
13/08 15:21:19,976 INFO [548170272784] (context.cpp:365) Found 0 RealSense devices (mask 254)
No devices found

The first two info line is the same at D415s, but it works well.
If I connect them directly to the windows-based PC and try to use Local Oneshot, they are working perfectly. So I think it would be some driver problem of the Odroid’s Ubuntu.

Could you give some advice what should we try to recognize D435s?

Thanks in advance,

Hello Viktor,

can you please try to update the camera’s firmware? This might already fix the problem. Also you can try to unplug and plug the device again.

If this doesn’t help please try to run one of the librealsense’s tools to see whether the camera is detected there. If it is not, you can try to search through similar issues reported on realsense forum, maybe you can find an explenation there. For example, here is a similar problem. Otherwise, you can try to ask your question on their Forum.

Best regards,

I tried your tips, unfortunately the camera isn’t recognized in Realsense Viewer either on Odroid’s Ubuntu, so I will try RealSense forum. Thank you.