Newbie scan question

Hello, on the advice of a support rep, I’m using RecFusion 1.6.4 with my Lenovo Yoga with built-in Intel RealSense F200 camera. I selected my bounding volume (30 cm cube), and set up a makeshift turntable. I’m trying to scan a tracheostomy tube for a medical application (I want to merge a model into a complex airway model derived from DICOM-formatted CAT scan data).

I didn’t see anything show up in the right pane when I was supposedly doing the scan, please let me know if I’m missing anything obvious. I would have expected my object to come up after the scan.

Link to video showing scan process : Dropbox - 2021-08-09 - Simplify your life


With the assistance of the support agent, I was able to size and properly position the capture volume, but the results are not what I expect. Please take a look at the enclosed video and let me know if I’m doing something wrong, or if this points to a hardware / software issue. Thanks. Dropbox - 2021-08-11 - Simplify your life.
UPDATE I later realized that I had my son’s Tobii eye tracker, which was interfering with the RealSense camera. I’ll post another video soon as even with the eye tracker unplugged I was still unable to get anything recognizable after the capture.

The reconstruction volume must not contain any static structures in the background such as the piece of cloth. You can also try to limit the capture depth of the sensor to a distance which removes the background. This can be done via the sensor settings tab.
Finally, please make sure that there are depth measurements on all of the object if possible (empty areas in the depth view indicate missing data) and try to turn the object very slowly.

OK, good suggestions. I limited the sensor depth and removed the black background. The object shows green on the depth map in all dimensions, but still shows blue on the scan and no result is obtained. Suggestions? Dropbox - 2021-08-11 - Simplify your life

Could you please record and send a sequence to us? There is a button “Record sequence” for that. Just slowly rotate the object as you did in the previous viseo during recording. We will try to do the reconstruction offline. In the video you sent us all the settings seem to be fine, so we can’t say why the reconstruction doesn’t work just from the video.

Best regards,

OK, here’s a sequence for discussion.

We took a look at the sequence, and most probably the issue here is that the object that you are trying to scan is too small and is also symmetric. What you can try is the following:

  • using a tape attach some bigger object to the lower part of the tube, it can be some box for example (attach it somewhere in the area marked with red)
  • set up the minimum size of the bounding volume and use a high resolution (marked in blue)
  • scan your object together with the temporarily attached object
  • if the scan is successfull, you can crop away the added object

Best regards,

Tried the following with no success. Ideas? Dropbox - TrachTubeWithBox.rfs - Simplify your life

Another failed attempt Dropbox - TraceTubeWithFigurine.rfs - Simplify your life

It seems that the object is just too small and the consumer cameras are just not good enough for this type of scanning. Industrial scanning would be the way to go with such objects.

OK, I’ll keep on searching for software that may be able to handle my sensor. On to LIPS …

I also tried pasting little dots on the structure, as was recommended to me by somebody knowledgeable in this field, but the result was less than satisfactory.

We only use the depth data for tracking and no color data. That’s why adding color markers will not make any difference

I now have a complete scan of this smooth small object using a David 3D scanning system, despite the fact that I was getting clean data from F200 RGB and depth cameras. I am very sad that RefFusion software couldn’t handle this object. The David SLS-1 structured light scanner appears much more fit for purpose in my case.