Labels crashing when trying to import data

I am trying to use Labels. I used it before on another workstation and it was perfectly fine but on this machine it crashes whenever I want to scan a folder to add data.
It’s a Ubuntu 18 w/ 2 Titan GPUs and 32 GB of RAM and I am using ImFusionSDK 2.23.1.

The steps I took:

  • $ ImFusionLabels
  • new Project
  • choose an empty folder as Folder
  • Image Segmentation as Type
  • click on the + button
  • choose other files tab
  • go to the directory where the images are

then it crashes and below is the output in the terminal. I tried with different image types but the result is the same.

***** Encountered fatal exception: SIGSEGV - Segmentation violation signal, PID 31188 *****
	stack dump [1]  /lib/x86_64-linux-gnu/ [0x7f117bf9df20]
	stack dump [2]  [0x5589e3c1c800]

Any Idea on what is causing this?

Downgrading to 2.19 solved my problem.


Dear Farid,

Thank you very much for the detailed bug report.
It seems that we can reproduce this issue, we will investigate [internal ticket number AS-303] and keep you updated.



I just wanted to say that we’ve tracked down and fixed the issue. We’ll provide you with an installer soon, sorry for the inconvenience.