Import tracking stream through IGT connection unsuccessful

Hi, I am encountering an another trouble while I tried to connect a tracking stream driven by NDI Aurora tracking system in Imfusion Ultrasound Suite v3.5 academia. I tried to connecting the tracking stream by algorithm IGTconncection. Things went well at first that it can identify the tracking stream called NeedleToTracker. However the transform can not be found anywhere in Imfusion. They can not be visualized or inspected etc…So the calibration pipeline can not be carried on. Could you please help me out with that? A scene is shown as follows which no tracking stream data can be found.

p.s. this pipe works in Imfusion Suite v3.1 however goes wrong in v3.5.

it is a bit hard to debug with the screenshot and the current information. Do you start this with a workspace which you could share? Alternatively, can you explain how you connect to the tracking system? I do not understand your setup at the moment and how you use the IGTconnection to connect to the NDI tracking system.

Additionally, could you show the log messages from the beginning?


Hi, Christian
I am Jack Lin’s colleague, and I am here to address the questions you raised. The steps of our IGTconnection operation are as follows:

  1. We use Plus Toolkits to connect NDI Aurora and send messages to the client through IGTLinkServer.
  2. In ImFusion, we open the IGTLink Connection, select the corresponding port, and generate the IGTLink Client.
  3. Successful creation of the IGTLink.
  4. Open the IGTLink Data IO within IGTLink.
  5. In the IGTLink Data IO, select DeviceType: Tracking Stream, Data Type: TRANSFORM. The DeviceName automatically appears based on the data name defined in PlusServer. Click Compute.

However, despite these steps, there is no Tracker data visible in the visualization window.

Thanks for the details. I’ll try to reproduce this and we will investigate it.

I’ll keep you posted as soon as there are any news!


UPDATE: I could reproduce your results and we will fix this in one of the upcoming installer updates. Sorry, for the inconvenience. Once the fixed version is out, I’ll let you know.

Hi all,

the latest academic installer includes a fix for this problem. It is available here: