Failed to initialize COM: using SDK 2.2

When I tried to integration with SDK 2.2, we are encountering Failed to initialize COM: error. It happend in m_rec = new Reconstruction(params);. Is there any requirement when calling new Reconstruction? Thx.


there are no special requirements. Could you please specify the full error or better send us the log output?

Thank you,

Pls ignore this problem. It is my fault on Initing Network. But after solved it, It seems reconstruction shutdown immediately. Check the log as following.

2022-03-17 13:14:29.749 INFO Image recorder thread started
2022-03-17 13:14:31.469 INFO Added keyframe (1,-1) R inf T inf
2022-03-17 13:14:32.10 INFO Image recorder thread terminated
2022-03-17 13:14:32.13 ERROR Invalid file format
2022-03-17 13:14:32.13 ERROR [RGBDSequenceRfs] Invalid file C:/Users/xxx/AppData/Roaming///0/0.rfs

Any comments on this? Thx.

Does this happen with your custom code or with one of our samples? If it’s your custom code, could you please try to run one of our samples to see whther it happens there. Which sensor are you using?