Export - Output file format - no nifti available

I am trying to export my project to nifti (compressed) files.
I created the project by copying the unlabled nifti files into an imfusion labels project. I did not notice any difference to my previous project where it just worked fine but this time the option for nifti is not available in the Export page under Output file format. I only see .dcm, .mhd, .imf, hd5.

sorry for the bad screenshot :sweat_smile: - As you can see there is no option to export Nifti available.

Dear all,

First of all, thank you for the feedback.

To the extent of my knowledge, NIFTI files don’t support images with an arbitrary number of channels, apart from one configuration: 8-bit RGB images.
Since we only distinguish between projects with 1-channel (grayscale) images and multi-channel images, we had to disable the NIFTI format during export for the latter.

What we could try to do instead is to allow it only if all images are 8-bit RGB images.
I will open an internal ticket for that and keep you posted.

Did I understood it correctly that if you load NIFTI CTs the option to export NIFTI is not available. If you load DICOM CTs export to NIFTI is enabled?

1 Like

What I mean is: regardless of how the data has been imported, it is currently not possible to export them as NIFTI if the project has been defined as “multi-channel” (because NIFTI does not support multi-channel, apart from a specific case: RGB 8-bit images).

  • If you have grayscale images, you should not have this problem (having a non multi-channel project should enable the option).
  • If you have RGB 8-bit images, we will try to work on a fix so that you can still export your data
  • If you have a different kind of multi-channel images, then it is not possible to export the data as NIFTI
  • greyscale = 8bit = [0-255] values possible per pixel?

We have CTs with hounsfield units so one channel with values from -1000 to roughly 2000 not an RGB image.

  • as labels we have 5 binary classes

I am only interested in the export of the labels not in the image.

So probably I only need to find a way to change the project to a non multi-channel project right?

The Export tab is meant to export images and labels in a consistent way. Since there might be some processing applied (resampling, baking in the patient orientation, etc), the images will always be re-exported as well. In particular, they will be renamed in the output folder with an index (even though you will get the correspondence to the original data in a text file).

However, you can export manually each label map from the Database tab by right clicking on a dataset and going in the Export context menu.

Regarding the last question, I am not sure whether you can change the project data type from the UI, but you can try to directly edit the xml file in the project folder.
Warning: Please make a backup copy of the project before.
Look at the project version number and also spot the dataType parameter (they should be defined on the first lines of project.xml)

  • If the project version is lower than 11, then try setting the dataType parameter to 1 (if you have 2D images) or 3 (if you have 3D volumes).
  • If the project is greater or equal to 11, then set the dataType parameter to 1 (if you have 2D images) or 4 (if you have 3D volumes)

By changing the project file from:

<propertyfile version="1.1">
    <param name="version">12</param>
    <property name="project">
        <param name="name">Lobes</param>
        <param name="projectType">1</param>
        <param name="dataType">15</param>


<propertyfile version="1.1">
    <param name="version">12</param>
    <property name="project">
        <param name="name">Lobes</param>
        <param name="projectType">1</param>
        <param name="dataType">4</param>

I could resolve the problem. So as you mentioned the dataType/ImageType has to be 4/GrayScale3D

Thanks again!

1 Like