Error (kernelbase.dll) while using the new SensorManager from RecFusion SDK 2.2.0

When I am using the new RecFusion SDK 2.2.0, I get an error while instantiating the SensorManager class:

SensorManager sensor_manager;
// or
SensorManager* sensor_manager = new SensorManager();

During the debugging in Visual Studio 2019, I get the following error:

0x00007FFB63444F99 (KernelBase.dll) in sensor-laser-test.exe: 0xC06D007E: Module not found (0x000000D6101FF4A0)

In the Event Viewer I get:

An error:

Faulting application name: sensor-laser-test.exe, version:, time stamp: 0x61e89476
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1466, time stamp: 0xe01c7650
Exception code: 0xc06d007e
Fault offset: 0x0000000000034f69
Faulting process ID: 0x20b8
Faulting application start time: 0x01d80d86d16b0e85
Faulting application path: E:\sensor-laser-test\bin\Release\sensor-laser-test.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report ID: fc276ffb-7973-49dd-b50c-92155732043e
Faulting package full name:
Faulting package-relative application ID:


Fault bucket 1732771248119832550, type 4
Event Name: APPCRASH
Response: Unavailable
Cab Id: 0

Problem signature:
P1: sensor-laser-test.exe
P3: 61e89476
P5: 10.0.19041.1466
P6: e01c7650
P7: c06d007e
P8: 0000000000034f69

I tried the following:

  • Running the code on two different Windows 10 machines
  • Updating the Windows with all available updates
  • Reinstalling the SDK, OpenNI 2.0 and GPU drivers
  • Testing the code with (Asus) and without connected sensors

Could you help me and direct me towards the possible cause? Thanks!

Does the crash also happen with the samples which are provided with the SDK? If not, can you please send us a minimal example which triggers the crash?

Yes, it does. The compiled binaries work, but not the provided samples compiled on my machines. The problem still lay in the instantiation of the SensorManager().

I am going to change the compiler version and see. But, I am afraid the problem is more in the intersection between the OS and the compiler.

Unfortunately, we didn’t manage to reproduce this problem. Is there any update on your side? Does the crash happen both in debug and in release mode?

Also can you please check that the Visual Studio loads the dlls from the bin folder of the RecFusion SDK and no dlls that are on your computer and might have a mismatching versions to those from SDK?

Hi, I haven’t had time to get back to the problem. However, I will probably have this or next month so I will keep you updated :slight_smile:

The crash happens in, both, release and debug modes. I am quite sure that the binary loads the right DLLs as I copy them and the binary together to a new directory. Nevertheless, I will double or even triple check it with dumpbin/Dependecy Walker. I still need to do more investigation and testing. I keep you posted.

Sorry, I was mistaken. The compiled samples worked correctly, and on my side, the problem was the commented out call to RecFusionSDK::init(). Mentally, I am still in the RecFusion 1.3.6 version, apparently :slight_smile:


No problem :slight_smile: Thank you very much for the update!

1 Like