Convolution settings for ultrasound simulation

Hi, I am trying to simulate a ultrasound sweep using the hybrid ultrasound simulation algorithm for the label map showed in the following figure (blue: muscle, yellow: fat, cyan: soft tissue, orange: bone). But with the default settings, the generated image is far from a real US image. After selecting Do not use convolution, it looks more reasonable:

So here I am a little confused. From my understanding, convolution should make the resulting image become more realistic, right? Is it because I use a wrong set of Conv. parameters? Do you have any suggestions for this?

Hi Yunke,

This convolution isn’t about convolving the final image with anything, e.g. a filtering kernel. Instead, it refers to the internal convolution with the background noise volume as the rays traverse through the label map, generating the tissue-specific speckle pattern. If you turn it off, you won’t see speckle but only the pure reflection patters between tissue boundaries. Otherwise, the final ultrasound image is a mixture of these two things: the reflections and the speckle, subject to some normalization.

I can see that the image parameters itself need some adjustments. If the attenuation parameter or the TGC scale are too low, you might end up with higher intensities at the bottom of the image for numerical reasons. Also note that the tissue-specific attenuation coefficients should be set to moderate values for the soft tissue parts, because otherwise too much energy is absorbed before it even reaches the bone, thus making the reflection weaker.